INFORMATION TECHNOLOGY- 402
CLASS - X

UNIT - II: Electronic Spreadsheet (Advanced)

CHAPTER — 6: ANALYSING DATA IN A SPREADSHEET

ASSESSMENT TIME

A. Select the correct option.

1.
2.
3.
4.
5.

a. Consolidate
c. Subtotals

b. Data Tools
c. Scenario

b. Goal Seek

B. Fill in the blanks.

U gy =

Set of values
Sorted

Data Table
Goal Seek
Solver

C. Answer the following questions.

1.

Data Consolidation: Consolidating data means combining data from different sources into
one place. For example, you have sales data from four different zonal heads in four
different worksheets. In such a case, to analyse data, you need to collate everything into one
worksheet. It will become a tedious and tiresome task, if you combine it manually using the
traditional way of copying and pasting. Excel provides the Consolidate feature that lets you
collate the data with minimal efforts. It selects the contents of the cells from several
worksheets and maintains the collected data in a master worksheet.

A scenario is a set of values that you enter in a worksheet to perform calculations. You can
easily create, edit, and format different groups of values (in form of scenarios), and name
them as per your choice. You can create as many scenarios as you want and then compare
them without changing the values, manually.

Goal Seek is another useful data analysis tool of Excel. It is used to set a goal to find the
optimum value for one or more target variables, given with the certain conditions. It allows
you to try different values in the formula to arrive at a solution for the input value. In other
words, Goal Seek is another What-If Analysis tool that helps you obtain the input value that
result in the target value that you want.

Scenario Manager: It is an important tool of Excel, which you use to test the ‘What-If’
guestions. It enables you to manage and view data from different input values. Forexample,




if you want to calculate the effect of different interest rates on an investment, you could add
a scenario for each interest rate, and quickly view the results.

Data Table: is a way to see different results by altering an input cell in your formula. Instead
of creating different scenarios, you can create a data table to quickly try out the different
values for the formulas. You can create a one or two variable data table.

CHAPTER — 7: LINKING DATA AND SPREADSHEETS

ASSESSMENT TIME

A. Select the correct option.

1.
2.
3.
4.
5.

a. Sheet name

b. /Picture.jpg

a. Insert

b. Data > From Access
c. Ctrl + K

B. Fill in the blanks.

L R

Updated

Home, Insert
Reference
Hyperlink

Relative Hyperlink

C. Answer the following questions.

1.

Linking spreadsheet data enables you to keep the information updated without editing in
multiple locations, every time the data changes. The ability to create links eliminates the
need of having identical data entered and updated in multiple sheets. This saves time,
reduces errors, and improves data integrity. It is a quick way to get the data from one
worksheet to another by using the ‘copy and paste’ method.

When you launch Excel on your computer, it opens a worksheet, named Sheetl. You can add
as many worksheets as you want. To insert a new worksheet, click on the Insert Worksheet
button beside the sheet tabs, or choose Home > Insert > Insert Sheet from the menu bar, or
press Shift + F11. This inserts a new sheet in the current workbook.

Relative Hyperlink: A relative hyperlink contains a partial address, which is relative to the
address of the destination file. For example, you have saved a workbook ABC.xlsx and an
image file Capture.jpg in D: drive. To create a relative hyperlink of the image file to the
workbook, the relative path will be \Capture.jpg. Relative linking is only possible when both
the source and destination files are on the same drive or location. However, a relative link
will break if any of the files (source or destination) is moved from its location.

Absolute Hyperlink: An absolute hyperlink is a hyperlink that contains the full address of the
destination file or web page. The following are examples of absolute hyperlink:

https://kips.in/index.php/books
C:\Users\KIPS\Documents




You can insert data in a spreadsheet from different external sources, such as from MS
Access, Web, Text, and other sources (SQL Server and XML Data Import). When you import
data, you make a permanent connection that can be refreshed, whenever required. Import
the data from Access to the Excel worksheet. To do so, follow the given steps:

Open the Excel worksheet in which data is to be inserted from an external source.

Open the Data tab and choose the From Access option from the Get External Data group.
The Select Data Source dialog box opens. Choose a database file and click on Open.

The Select Table dialog box opens. Choose the desired table.

The Import Data dialog box opens.

Choose the Table option to view data in a tabular format.

Also, choose whether you want to put the data in the Existing worksheet or in a New
worksheet. Click on OK.

The Access table is displayed in the worksheet.

CHAPTER — 8: SHARING AND REVIEWING A SPREADSHEET

ASSESSMENT TIME

A. Select the correct option.

L

a. Review

a. Review > Track Change > Show Changes
a. Accept / Reject Changes

c. Changes

b. Resolve Conflicts

B. Write T for True and F for False.

B W g

- 4 m +

C. Answer the following questions.

1.

When you share a worksheet, multiple users can work on it simultaneously. They can enter
data, insert rows and columns, add and change formulas, and also format the same
spreadsheet. To share a spreadsheet, follow the given steps:

e  Start the Microsoft Excel 2010 application.

e  Open the file you would like to share, or create a new file.

e Saveitin a network location, so that the other users can access it easily.

e With the workbook open, switch to the Review tab.

e  Click on the Share Workbook option in the Changes group.

e  The Share Workbook dialog box opens as shown in Figure 8.1.

e Select the Allow changes by more than one user at the same time. This also allows
workbook merging checkbox to enable sharing.

e (Click on OK. If you have already saved the spreadsheet, a message appears stating that
the action will now save the workbook; click on OK to continue. If the workbook has not




been saved previously, the Save As dialog box appears. After saving, the word [shared] is
shown on the title bar along with the document’s title.
e Now, all the users can work together on the same workbook.
Sometimes, you may be required to record the changes done by you or the other usersin a
spreadsheet to review later. The Track Changes feature in Excel is used for this purpose. It
enables you to keep a track of the changes done by you or the other users in a spreadsheet.
Track changes records the usual changes, such as addition, deletion, content alterations,
formatting, and makes the changes visible in order to ease the review process. However, not
all changes are recorded; likewise, the change in the alignment of cell content is not
recorded. Changes can be accepted or rejected by the user.
Comments help in providing some extra information on the data stored in a cell. They play
an important role to add some facts, tips, or feedback for the user.
Sometimes, you have different versions of the same spreadsheet, and you want to view all
the changes and comments of all the users in one go. In such a case, the Compare and
Merge Workbook feature of Excel can be used. It is a useful tool that allows you to compare
all the changes made by the different users and merge them into a single file. It also
addresses the users when you accept or reject the changes.

CHAPTER — 9: USING MACROS IN A SPREADSHEET

ASSESSMENT TIME

A. Select the correct option.

= P =

c. View

c. View > Macros > View Macros
a. Function

a. Alt + F11

B. Fill in the blanks.

e SR

Macros
Keystrokes
Function

Name, Parameters

C. Answer the following questions.

1.

Macros are small programs that record your actions as you perform a task in Excel. When
you run the macro later, it repeats your keystrokes and thus actions. This is why macros are
great for automating repetitive tasks. The Macros feature of Excel allows you to record a set
of actions that you perform repeatedly in a spreadsheet. You can run a macro as many times
as you want. They automate the recorded actions and save your time and efforts. Macros
are very useful when you have to repeat the same task in the same way, over and over
again.
Follow these steps to record a simple macro:

e Click on the View > Macros > Record Macro.

e The Record Macro dialog box opens as shown in Figure 9.1.

e Type a name for the macro, for example, KIPS in Macro name field. By default, Excel

gives the name Macrol.




3.

e  Assign a shortcut key Ctrl + Shift + K in the Shortcut key field. This key combination
will be used to execute the macro later on, i.e., when you press the assigned key
combination, the operations recorded in the macro will get automatically executed.

e Inthe Store macro in list box, choose where the macro is to be made functional. By
default, the macro works in the current workbook.

e You can also provide some description related to the macro in the Description box.
This is optional.

e Click on OK to start recording the macro.

e Perform the operations that you want to record in the macro.

e C(Click on View > Macros > Stop Recording to finish the recording of the macro. Press
the keyboard shortcut (here, Ctrl + Shift + K) to execute the macro. Or

e C(Click on the View > Macros > View Macros. Select the name of the macro that is to
be executed and click on Run. Observe that the operations recorded in the macro
get automatically performed.

A function is a line of code that gets executed on function calling. When you call a function,
it gets invoked and returns result as per the code. To define a macro as a function, use the
keyword Function. Each function has a name and may have parameters whose values you
pass when you call the function.

Syntax:

To define a simple function without parameters:

Function Function_Name ()

Body of Function

Function_Name=Result

End Function

Sub sbGetCellData()

MsgBox Cells (1, 4)

End Sub

BRAIN DEVELOPER

Section 4: Application Based Questions (Unsolved)

1.

B S

Goal Seek

Locate the file in network location and double-click on it to open it.

Click on Review>Track Changes>Accept/Reject Changes.

Use Compare and Merge Workbook feature.

Click on View> Macro> View Macros, select the macro name from the Macros dialog box and
choose Run.

Section 5: Short Answer Type Questions (Unsolved)

1.

2.

If the spreadsheet has been opened and modified by another user since you opened it, there
may be come chances that the changes conflict while saving it. In such situation, the Resolve
Conflicts dialog box opens. Here, you must decide which version of the conflict to keep, by
clicking on Accept Mine or Accept Other option. When all the conflicts are resolved, the
document is saved.

The ‘What-If’ Analysis tools of Excel allow you to use different sets of values in one or more
formulas to explore all the various results.

e Scenario Manager is an important tool of Excel, which you use to test the ‘What-If’
guestions. It enables you to manage and view data from different input values.




e Goal Seek is another useful data analysis tool of Excel. It is used to set a goal to find
the optimum value for one or more target variables, given with the certain
conditions. It allows you to try different values in the formula to arrive at a solution
for the input value.

3. To add a comment, follow the given steps:

e Select the cell on which you wish to apply comment.

e Open the Review tab and choose New Comment.

e The comment box pops-up.

e Enter the comment and click anywhere outside the comment box.

e The cell having comment will show a red dot on its top-right corner.

4. Follow these steps to record a simple macro:

e C(Click on the View > Macros > Record Macro.

e The Record Macro dialog box opens.

e Type a name for the macro. By default, Excel gives the name Macro1.

e Assign a shortcut key to the macro. This key combination will be used to execute the
macro later on.

e C(Click on OK to start recording the macro.

5. Visual Basic

Section 6: Long Answer Type Questions (Unsolved)

1. Scenario Manager enables you to manage and view data from different input values. A
scenario is a set of values that you enter in a worksheet to perform calculations. You can
easily create, edit, and format different groups of values (in form of scenarios), and name
them as per your choice. You can create as many scenarios as you want and then compare
them without changing the values, manually.

Whereas, Data Table is a way to see different results by altering an input cell in your
formula. Instead of creating different scenarios, you can create a data table to quickly try
out the different values for the formulas. You can create a one or two variable data table.

2. Goal Seek is a useful data analysis tool of Excel. It is used to set a goal to find the optimum
value for one or more target variables, given with the certain conditions. It allows you to try
different values in the formula to arrive at a solution for the input value. Solver is another
What-if Analysis tool. It follows the Goal Seek method to solve the equations but more
elaborately. The only difference between Goal Seek and Solver is that the Solver deals with
equations with multiple unknown variables. It is the elaborate form of Goal Seek.

3. To create a named range in Excel, follow the given steps:

e Select the range of cells.

e Click on Data > Define Range.

e The Define Database Range dialog box opens. Specify a name for the range in the
Name field and then click on OK.

4. Sometimes, you have different versions of the same spreadsheet, and you want to view all
the changes and comments of all the users in one go. In such a case, the Compare and
Merge Workbook feature of Excel can be used. It is a useful tool that allows you to compare
all the changes made by the different users and merge them into a single file. It also
addresses the users when you accept or reject the changes. To merge spreadsheet, follow
these steps:




e QOpen a copy of the shared workbook.
e Click on the Compare and Merge Workbooks option on the Quick Access Toolbar.
e The Select Files to Merge into Current Workbook dialog box opens.
e Select another copy of the same shared workbook you want to
merge. To select multiple copies, hold the Ctrl or Shift key on
your keyboard while selecting the file names.
e Click on OK. The changes from each copy of the shared
workbook will be merged into a single copy.
A macro acts as a function. You can pass arguments (values /
parameters) to a macro when you call it. To allow a macro to accept a
value, simply type a name for that value between the parentheses at the
top of the macro.

To define a macro with parameters:
Function Function_Name (Optional Parameterl, Optional
Parameter2,...) Program code
FunctionName=Result

End Function

To pass arguments to a macro while calling it in Excel directly by entering
the function name and argument(s) in a cell:

=Function_Name(Parameterl, Parameter2,...)
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